Jan
11
2011

Test de la faille PHP 5.3.5 et 5.2.17 sur les serveurs 32bits

Une faille vient d’apparaitre sur PHP,

Celle-ci concerne un problème qui n’est constaté que sur les serveurs 32bits.

Il s’agit d’un problème venant d’un algorithme de programmation sur la virgule flottante.

Il faut savoir que le problème se situe sur un nombre qui est mal interprété : 2.2250738585072011e-308

Le problème est le suivant, quand ce chiffre est interprété par PHP , celui-ci consomme 100% du CPU et reste figé sur ce bout de code.

Si vous voulez tester si votre serveur est sécurisé contre cette faille , je vous fournis un code:

Si vous voyez sur votre navigateur : Pas de problèmes vous n'avez rien à craindre.

Sinon faite une mise à jour/upgrade de PHP !

Laisser un commentaire

*